php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8635 Missing symbols when linked with ucd-snmp 4.2
Submitted: 2001-01-10 08:18 UTC Modified: 2001-01-11 08:21 UTC
From: marc dot daumas at urssaf dot fr Assigned:
Status: Closed Package: SNMP related
PHP Version: 4.0.4 OS: Suse Linux 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: marc dot daumas at urssaf dot fr
New email:
PHP Version: OS:

 

 [2001-01-10 08:18 UTC] marc dot daumas at urssaf dot fr
When you try to build PHP-4.0.4 with libsnmp 4.2 installed
on your system, libphp4.so is build but des_* symbols are 
missing.
when Apache tries to load the lib
Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/libsnmp-0.4.2.so: undefined symbol: des_cbc_encrypt
Applications dynamicaly linked with libsnmp 4.2 must be linked with libdes.a
How can I add that library ?                                        

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-11 08:21 UTC] sniper@php.net
You need openssl. Add --with-openssl=/path/to/install/dir into your configureline. (you have to have openssl 
installed in your system)

--Jani

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 19 14:01:26 2019 UTC