php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8613 apache configure doesn't find xmltok
Submitted: 2001-01-09 07:20 UTC Modified: 2001-01-11 11:14 UTC
From: douglasd at ausisp dot net Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.4 OS: Redhat 7.0
Private report: No CVE-ID: None
 [2001-01-09 07:20 UTC] douglasd at ausisp dot net
This relates to including the sablotron XML parser.

Php builds fine but when I run apache's configure script I get these errors:

Creating Configuration.apaci in src
cd ..; gcc  -DLINUX=2 -I/usr/local/src/php-4.0.4........
........ -lxmltok -lxmlparse .....
/usr/bin/ld: cannot find -lxmltok
collect2: ld returned 1 exit status




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-09 08:10 UTC] derick@php.net
sablotron (which version are you using?) needs the Expat library, so that's the source of your problem. Either install Expat yourself or compile sablotron with Expat (only possible if using versions 0.4x iirc). Anyway, I think the configure script should check if these library's are on a system, so that's what I'll add. Or am I saying nonesence here Sterling?
 [2001-01-11 11:14 UTC] sniper@php.net
This should be fixed in CVS now. Please try latest snapshot
from http://snaps.php.net/ and add 
--with-expat-dir=/path/to/expat/install/dir 
to your configure line.

--Jani


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 06:05:46 2022 UTC