php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8512 SIGSEGV when output_handler set to ob_gzhandler
Submitted: 2001-01-02 03:45 UTC Modified: 2001-05-11 21:13 UTC
From: M dot Hankus at ce3 dot pl Assigned:
Status: Closed Package: Output Control
PHP Version: 4.0.4 OS: Linux 2.2.18
Private report: No CVE-ID: None
 [2001-01-02 03:45 UTC] M dot Hankus at ce3 dot pl
When output_handler is set to ob_gzhandler apache receivs SEGV.
My configuration is as follows
PHP 4.0.4 statically linked with apache 1.3.14

PHP was configured with
'./configure' '--with-apache=../apache_1.3.14' '--without-mysql' '--enable-track-vars'
                            '--with-zlib' '--enable-gd-imgstrttf' '--with-gd' '--with-pgsql'
                            '--with-swf=/usr/local/swf'

zlib version 1.1.3

and backtrace is

Starting program: /usr/local/apache/bin/httpd -X
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x80e1c04 in call_user_function_ex ()
(gdb) bt
#0  0x80e1c04 in call_user_function_ex ()
#1  0x80c81ca in php_end_ob_buffer ()
#2  0x80c8386 in php_end_ob_buffers ()
#3  0x80f2f6b in apache_php_module_main ()
#4  0x807da6b in send_php ()
#5  0x807da98 in send_parsed_php ()
#6  0x8116903 in ap_invoke_handler ()
#7  0x812a139 in ap_some_auth_required ()
#8  0x812a19c in ap_process_request ()
#9  0x8121a1e in ap_child_terminate ()
#10 0x8121bac in ap_child_terminate ()
#11 0x8121d09 in ap_child_terminate ()
#12 0x8122336 in ap_child_terminate ()
#13 0x8122ac3 in main ()
#14 0x40135736 in __libc_start_main () from /lib/libc.so.6

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-02 09:21 UTC] sniper@php.net
Duplicate of #8334

--Jani
 [2001-05-11 21:13 UTC] sniper@php.net
Fixed in PHP 4.0.5

--Jani

 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Oct 22 10:01:26 2018 UTC