php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8477 apache 1.3.12 DSO warning
Submitted: 2000-12-29 10:53 UTC Modified: 2001-05-27 21:56 UTC
From: fang-pin dot chang at cyberdude dot com Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.4 OS: MacOS X Public Beta
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fang-pin dot chang at cyberdude dot com
New email:
PHP Version: OS:

 

 [2000-12-29 10:53 UTC] fang-pin dot chang at cyberdude dot com
I did a

    ./configure --with-apxs --with-mysql

and then a

    make install

All seems fine, except when I did a apachectl start, 
apache comlains of the following:

[Fri Dec 29 07:27:43 2000] [warn] Loaded DSO /
System/Library/Apache/Modules/libphp4.so uses plain 
Apache 1.3 API, this module might crash under EAPI! 
(please recompile it with -DEAPI)
/usr/sbin/apachectl start: httpd started

However, the warning is not produced if I take the '--
with-mysql' out of the ./configure command line.

I then looked up EAPI in the bugs database, and found 
#3918 where the use of

    '--enable-rule=EAPI'

was mentioned.  So I did the same, and found as the 
reporter did, that -DEAPI line was not produced while 
compiling, which resulted in the same warning as 
before.  I must say, though, that ./configure --help did 
not reveal that particular option.

Then bug #3583 revealed that a manual hack of the 
configure script worked for the reporter.  So I appended 
-DEAPI to CPPFLAGS for the darwin platform, and 
verified that the -DEAPI is being included in all compile 
(and link) lines.  However, the same warning still 
occurs whenever I do a

    apachectl start

Please advise.  Thanks!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-27 21:56 UTC] sniper@php.net
the apxs program that is found by configure is different
than the one your installed apache has. Not a bug. 
Try adding the full path to the correct apxs.
like this: --with-apxs=/www/apache/bin/apxs

--Jani


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jun 28 19:05:44 2022 UTC