php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8423 Date format in 4.0.3 and 4.0.4 is different for MSSQL
Submitted: 2000-12-26 11:13 UTC Modified: 2000-12-26 13:43 UTC
From: jlim at natsoft dot com dot my Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.0.4 OS: Windows 98
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jlim at natsoft dot com dot my
New email:
PHP Version: OS:

 

 [2000-12-26 11:13 UTC] jlim at natsoft dot com dot my
The standard data format in all database extensions previously was YYYY-MM-DD hh:ii:ss

The lastest version appears to change it to the following:

  27 Dec 2000 12:00AM 


Using the TSQL command SET DATEFORMAT YMD does not change it back to y-m-d.  The only other thing I can think of is that I recently upgraded to MDAC/ADO 2.6. Would that cause a problem?



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-26 13:43 UTC] jlim at natsoft dot com dot my
Sorry not a bug in PHP. A bug in my brain. Please close.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jul 07 04:03:36 2022 UTC