php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8418 ii.c (Ingres) fails to compile with gcc
Submitted: 2000-12-25 17:10 UTC Modified: 2001-05-23 15:37 UTC
From: mrodal99 at grm dot hia dot no Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.0.4 OS: Solaris 2.5.1
Private report: No CVE-ID: None
 [2000-12-25 17:10 UTC] mrodal99 at grm dot hia dot no
I get the following error when I try to compile php 4.0.4 with the "--with-ingres" support.

gcc  -I. -I/opt/nmc/users/nmcadm/morten/php-4.0.4/ext/ingres_ii -I/opt/nmc/users/nmcadm/morten/php-4.0.4/main -I/opt/nmc/users/nmcadm/morten/php-4.0.4 -I/opt/nmc/users/nmcadm/morten/apache_1.3.14/src/include -I/opt/nmc/users/nmcadm/morten/apache_1.3.14/src/os/unix -I/opt/nmc/users/nmcadm/morten/php-4.0.4/Zend -I/opt/nmc/ingres/files -I/opt/nmc/users/nmcadm/morten/php-4.0.4/ext/xml/expat/xmltok -I/opt/nmc/users/nmcadm/morten/php-4.0.4/ext/xml/expat/xmlparse -I/opt/nmc/users/nmcadm/morten/php-4.0.4/TSRM  -D_POSIX_PTHREAD_SEMANTICS -DXML_BYTE_ORDER=21 -g -O2  -c ii.c && touch ii.lo
ii.c: In function `_clean_ii_plink':
ii.c:191: `IIAPI_AUTOPARM' undeclared (first use in this function)
ii.c:191: (Each undeclared identifier is reported only once
ii.c:191: for each function it appears in.)
ii.c:191: parse error before `autoParm'
ii.c:200: `autoParm' undeclared (first use in this function)
ii.c: In function `php_if_ingres_autocommit':
ii.c:1350: `IIAPI_AUTOPARM' undeclared (first use in this function)
ii.c:1350: parse error before `autoParm'
ii.c:1363: `autoParm' undeclared (first use in this function)
*** Error code 1
make: Fatal error: Command failed for target `ii.lo'
Current working directory /opt/nmc/users/nmcadm/morten/php-4.0.4/ext/ingres_ii
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'

As you can see there seems to be a problem in the "ii.c" file.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-25 18:08 UTC] mrodal99 at grm dot hia dot no
I just noticed that the configure program gives me an 'error':

Generating files
checking for working mkdir -p... yes
creating config_vars.mk
updating cache ./config.cache
creating ./config.status
creating php4.spec
creating Zend/Makefile
creating main/build-defs.h
creating pear/pear
creating pear/phpize
creating pear/php-config
creating pear/PEAR.php
creating TSRM/Makefile
creating sapi/apache/libphp4.module
creating main/php_config.h
creating sapi/Makefile
creating ext/Makefile
creating Makefile
mkdir: "": No such file or directory
creating pear/Makefile
creating main/Makefile
creating ext/ingres_ii/Makefile
creating ext/pcre/Makefile
creating ext/pcre/pcrelib/Makefile
creating ext/posix/Makefile
creating ext/session/Makefile
creating ext/standard/Makefile
creating ext/xml/Makefile
creating ext/xml/expat/Makefile
creating ext/xml/expat/xmlparse/Makefile
creating ext/xml/expat/xmltok/Makefile
creating sapi/apache/Makefile
creating regex/Makefile
creating main/internal_functions.c

Notice that "mkdir: "": No such file or directory" in there
 [2000-12-28 09:07 UTC] sniper@php.net
What is the whole configure line you have used?
Is there anything unusual in config.log when
--with-ii is used? Does it work when it is not used?

--Jani
 [2000-12-28 11:51 UTC] mrodal99 at grm dot hia dot no
My entire configuration line was "./configure --without-mysql --with-ingres --with-apache=../apache_1.3.14", and if I don't have the "--with-ingres" in my configuration line everything works (but I really, really need the ingres database access). As you can see from my configure locates the ingres database (/opt/nmc/ingres/files) by it self so I dont think that is the problem.

I also did some research and I think that the ingres header file (iiapi.h?) which ii.h (from php) depends on havn't got the declaration of "IIAPI_AUTOPARM" (maybe a old version of ingres). At the moment I havn't got access to the computer (it's at work and I'm home for christmas), but I'll see if I can get hold of that "iiapi.h" file
 [2001-05-23 14:25 UTC] sniper@php.net
What's the status with this? This works for me just
fine with II 2.5/00 (int.lnx/97).

--Jani

 [2001-05-23 15:24 UTC] mrodal99 at grm dot hia dot no
After many hours of wacking my brain I found out the database was 'OpenIngres' and they are apparently not compatible with the IngresII support in php
 [2001-05-23 15:37 UTC] sniper@php.net
Bogusing this then.

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Apr 03 21:01:23 2020 UTC