php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8396 "document not found"
Submitted: 2000-12-24 01:15 UTC Modified: 2002-07-15 21:47 UTC
From: blake at auburnskies dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.0.3 OS: WIN NT/ IE 5.5/IIS 4.0
Private report: No CVE-ID: None
 [2000-12-24 01:15 UTC] blake at auburnskies dot com
on any other machine scripts work fine, everything performs as planned.  On my own machine, however, contacting scripts on my server through the lan causes the following error:

 The page cannot be displayed 
There is a problem with the page you are trying to reach and it cannot be displayed. 

--------------------------------------------------------------------------------

Please try the following:

Open the 192.168.0.2 home page, and then look for links to the information you want. 
Click the  Refresh button, or try again later.

Click  Search to look for information on the Internet. 
You can also see a list of related sites. 




HTTP 500 - Internal server error 
Internet Explorer  


I am behind a netgear router which doesnt allow me to directly access the domain.  This error was produced when doing a script using a POST type action, if i switch to GET the error is gone, but then my variable are open for the world to see...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-26 14:28 UTC] jmoore@php.net
This looks more like a config error tahn a PHP error.
Please reopen this bug report if you are sure its a PHP error but the page your seeing certainly isnt generated by PHP.

- James
 [2002-02-17 10:00 UTC] smk at bigmediastudios dot com
I'm having this problem constantly, and it's NOT the page.
It happens when submitting data POST from one page to another, OR EVEN TO THE SAME PAGE, using a data form. Sometimes, it submits fine. Other times, it gives this error (document not found), in IIS only. If you go back and resubmit the EXACT SAME data to the exact same page, then you can submit succesfully. In Netscape, there is never this error.
What could possibley be causeing this intermittent error? Oddly enough, it seems to be related to how the form button behaves . . . if you click quickly, you are more likely to get the error. If you press the left button down, and hold it for a few seconds before releasing it, the error is muck less likely to occur.

NOTE: the form submit buttons, in this case, are <INPUT TYPE=IMAGE> rather than <INPUT TYPE=SUBMIT>

Any ideas, anyone?
Thanks,
Steve
 [2002-07-15 04:31 UTC] jonohlsson at hotmail dot com
Well, I dont think its an usererror. These 'refresh'-problems are
discussed and acknoledged att several forumcommunities using PHP 2.x.
Their PHP-coding works for PHP versions PHP.1.x but not 2.x. Symptons:
PHP-generated pages won't refresh. You have to empy browsers filecache
and reload. Very annoying for dynamic pages like forums. Please dont
ignore these messages believing they are usererror. Visit www.phpbb.com
(for example) and read the supportpages on "refresh".
 [2002-07-15 21:47 UTC] yohgaki@php.net
If you believe it's a PHP's fault, you need to submit "short" and "complete" scripts that shows there is a problem. Then we may be able to fix it, otherwise we don't.

(It seems user error to me, also)



 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 02 14:05:53 2022 UTC