php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8310 Coredump when running php
Submitted: 2000-12-18 05:13 UTC Modified: 2001-06-04 05:07 UTC
From: s dot piton at sofrel dot com Assigned:
Status: Closed Package: PDF related
PHP Version: 4.0.3pl1 OS: AIX 4.3.2.0
Private report: No CVE-ID: None
 [2000-12-18 05:13 UTC] s dot piton at sofrel dot com
I have compiled PHP with this command line :
./configure --with-oci8 --with-pdflib

All is OK, configure OK, make OK, make install OK.

When I try to run php, I have this message : Illegal instruction (coredump)

I have PHP 4.03pl3 and pdflib 3.02.

Any ideas?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-28 16:20 UTC] jmoore@php.net
Can you please provide a back trace (see http://bugs.php.net) make sure to include --enable-debug in your command line.

James
 [2001-01-17 18:41 UTC] sniper@php.net
Does this happen with PHP 4.0.4pl1 ?

--Jani
 [2001-01-18 02:04 UTC] s dot piton at sofrel dot com
Yes, it happens with PHP 4.04pl1.

No solutions found yet.
 [2001-01-18 06:11 UTC] sniper@php.net
Do you have the Oracle related environment variables
set when you run ./php ? (Are you using PHP on the command line OR as a CGI? ) 

Check www.php.net/oci8 for info about the environment vars.

And if this doesn't help, please provide the gdb backtrace.

--Jani

 [2001-01-18 11:35 UTC] s dot piton at sofrel dot com
    It happens only when I compile php with pdflib, not when I compile php with Oracle.
    All is right with oci8. But when I try pdflib, I can't run php (coredump) after compilation of php&pdflib.

Spit
 [2001-02-26 08:34 UTC] sniper@php.net
How did you configure pdflib? 
Did you use  --enable-shared-pdflib option in the configure line when
you configured pdflib itself? 

--Jani


 [2001-02-26 10:06 UTC] s dot piton at sofrel dot com
Yes, I have used the --enable-shared-pdflib option.
I have no solutions yet. Waitin' for another pdflib version!!!
 [2001-06-04 05:07 UTC] sniper@php.net
This should be fixed in PHP 4.0.6. Please try latest
release candidate from:

http://www.php.net/~andi/php-4.0.6RC2.tar.gz

and also get the latest PDFlib sources ( 4.0.1)

--Jani

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 17:01:27 2019 UTC