php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8302 Warning: _oci_open_server: ORA-12547: TNS:lost contact in /usr/local/apache/htd
Submitted: 2000-12-17 11:59 UTC Modified: 2000-12-18 05:48 UTC
From: czuluaga at delta dot eafit dot edu dot co Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0.3pl1 OS: Intel based server Linux, Red Ha
Private report: No CVE-ID: None
 [2000-12-17 11:59 UTC] czuluaga at delta dot eafit dot edu dot co
Warning: _oci_open_server: ORA-12547: TNS:lost contact in /usr/local/apache/htdocs/prueba6.php on line 22

connect_test.html just has a simple OCILogon call to the database. The client and server Oracle software is set up with Net8 and works fine, it's only from the browser the error occurs. No tracing is produced at the Net8 level for the error.

can anyone give me any help.

Modules

oracle

           Oracle Support
                                            enabled
           Oracle Version
                                            8.1
           Compile-time ORACLE_HOME
                                            /usr/local/oracle/app/oracle/product/8.1.5


oci8

           OCI8 Support
                                            enabled
           Revision
                                            $Revision: 1.96 $
           Oracle Version
                                            8.1
           Compile-time ORACLE_HOME
                                            /usr/local/oracle/app/oracle/product/8.1.5/


We sent this error to oracle support, but they said us to go to this page, because the problem isn't from oracle.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-17 12:04 UTC] sniper@php.net
Did you set all the required environment variables before starting Apache?
Check this manual page:

http://www.php.net/manual/ref.oci8.php

--Jani
 [2000-12-17 12:07 UTC] czuluaga at delta dot eafit dot edu dot co
the correct name for php test is prueba6.php not connect_test.html
 [2000-12-17 12:23 UTC] czuluaga at delta dot eafit dot edu dot co
How we can set all the required environment variables before starting Apache?

We set this variables when the oracle user logon, but the apache server is always active.
 [2000-12-17 12:27 UTC] czuluaga at delta dot eafit dot edu dot co
How we can set all the required environment variables before starting Apache?

We set this variables when the oracle user logon, but the apache server is always active.
 [2000-12-18 05:47 UTC] sniper@php.net
I don't know which shell you are using but I use bash and it goes like this:

e.g.
# export LD_LIBRARY_PATH=/www/libs/

and then I would restart Apache so that it will use that variable..

--Jani

 [2000-12-18 05:48 UTC] sniper@php.net
And use this:

# /usr/local/apache/bin/apachectl stop
# /usr/local/apache/bin/apachectl start

!!

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Sep 29 02:05:55 2022 UTC