php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #81672 Missing support ed25519 authenticate method
Submitted: 2021-11-29 11:01 UTC Modified: 2021-11-30 01:56 UTC
From: simonwong at esdlife dot com Assigned: cmb (profile)
Status: Duplicate Package: PDO MySQL
PHP Version: 8.0.13 OS: RedHat
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: simonwong at esdlife dot com
New email:
PHP Version: OS:

 

 [2021-11-29 11:01 UTC] simonwong at esdlife dot com
Description:
------------
Disable connect MariaDB by using PDO with ed25519, will response authentication method unknown

PDO::__construct(): The server requested authentication method unknown to the client [client_ed25519]

Expected result:
----------------
Connection OK

Actual result:
--------------
PDO::__construct(): The server requested authentication method unknown to the client

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-11-29 11:23 UTC] cmb@php.net
-Type: Bug +Type: Feature/Change Request
 [2021-11-29 11:23 UTC] cmb@php.net
This is not a bug, but rather a feature request.  And since this
is actually an mysqlnd issue, a duplicate of request #81668.
 [2021-11-29 11:24 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2021-11-30 01:56 UTC] simonwong at esdlife dot com
Thanks cmb, agree this is new feature
Since Auth_ed25519 only used on MariaDB authentication method, and MySQL is not. Will the problem solving?
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 20:01:29 2024 UTC