php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81657 Imagick::getColorSpace() always returns 0
Submitted: 2021-11-25 11:56 UTC Modified: 2021-11-25 12:01 UTC
From: krejcir at ics dot muni dot cz Assigned: cmb (profile)
Status: Not a bug Package: *Graphics related
PHP Version: 7.4.26 OS: Debian 11
Private report: No CVE-ID: None
 [2021-11-25 11:56 UTC] krejcir at ics dot muni dot cz
Description:
------------
Calling Imagick::getColorspace() always returns imagick::COLORSPACE_UNDEFINED (0), no matter what is an input image. Trying to call CLI tool "identify" always returns correct color space.

This is observed on actual Debian 11: 
php  Version: 2:7.4+76
imagemagick Version: 8:6.9.11.60+dfsg-1.3
php-imagick Version: 3.4.4+php8.0+3.4.4-2+deb11u2

Test script:
---------------
<?php

$image = new Imagick($argv[1]);
var_dump($image->getColorSpace());

?>

Expected result:
----------------
! imagick::COLORSPACE_UNDEFINED

Actual result:
--------------
imagick::COLORSPACE_UNDEFINED

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-11-25 12:01 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-11-25 12:01 UTC] cmb@php.net
Please try with Imagick 3.6.0, and if the problem persists, please
report in the Imagick bug tracker[1].

[1] <https://github.com/Imagick/imagick/issues>
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 11:01:37 2024 UTC