php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #81594 Please add asynchronous multi_query
Submitted: 2021-11-06 06:38 UTC Modified: 2023-01-10 15:20 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: abecker at mailbox dot org Assigned:
Status: Wont fix Package: MySQLi related
PHP Version: Next Major Version OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2021-11-06 06:38 UTC] abecker at mailbox dot org
Description:
------------
The mysqli::query function accepts the MYSQLI_ASYNC flag, enabling fully asynchronous operation. mysqli::multi_query is missing this feature.

The documentation of mysqli::multi_query says, "Queries are sent asynchronously in a single call to the database". This is somewhat misleading, since the network operation is still synchronous, only the query execution is asynchronous. In case of a remote database server with latency, this obstructs the implementation of concurrency.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2023-01-10 15:20 UTC] dharman@php.net
-Status: Open +Status: Wont fix
 [2023-01-10 15:20 UTC] dharman@php.net
There are currently no plans to do that and it's highly unlikely that this would ever be implemented. 

If you really need this feature, please follow the RFC process, but let me personally say I would be against this feature.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Feb 22 05:01:28 2024 UTC