php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81526 --without-sqlite3 not working
Submitted: 2021-10-14 23:30 UTC Modified: 2021-10-15 03:50 UTC
From: fhorio at perforce dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 8.0.11 OS: CentOS 7
Private report: No CVE-ID: None
 [2021-10-14 23:30 UTC] fhorio at perforce dot com
Description:
------------
configure with --without-sqlite3 option doesn't work. I had to install sqlight-devel package in order to make it work.

./configure --with-zlib --enable-mbstring --enable-exif  --with-openssl=/usr/local/ssl/ --disable-cli --with-apxs2=/usr/local/apache2/bin/apxs  --enable-maintainer-zts --without-sqlite3 --disable-mbregex
.
.
.
checking for ODBC v3 support for PDO... no
checking for PostgreSQL support for PDO... no
checking for sqlite 3 support for PDO... yes
checking for PDO includes... /root/download/php-8.0.11/ext
checking for sqlite3 > 3.7.4... no
configure: error: Package requirements (sqlite3 > 3.7.4) were not met:

No package 'sqlite3' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SQLITE_CFLAGS
and SQLITE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-10-15 00:13 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2021-10-15 00:13 UTC] requinix@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

As of PHP 7.4 the sqlite3 library is no longer bundled and so must be installed separately.

https://www.php.net/manual/en/sqlite3.requirements.php
https://www.php.net/manual/en/migration74.other-changes.php
 [2021-10-15 03:50 UTC] requinix@php.net
...wow, I've not been doing well lately. But at least I was close.

--without-sqlite3 controls the sqlite3 extension. PHP will still require libsqlite3 if you try to compile support for pdo_sqlite - which the output in those few lines before the error message suggests it will be doing. You're probably encountering this now because of what I said before.

If you don't want pdo_sqlite either then use --without-pdo-sqlite.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 13:04:05 2022 UTC