php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81466 PHP 8.1.0RC2 build missing php_oci8_12c.dll
Submitted: 2021-09-22 15:58 UTC Modified: 2021-09-22 16:29 UTC
From: benjamin dot ho at cityofchicago dot org Assigned: cmb (profile)
Status: Not a bug Package: OCI8 related
PHP Version: 8.1.0RC2 OS: Windows
Private report: No CVE-ID: None
 [2021-09-22 15:58 UTC] benjamin dot ho at cityofchicago dot org
Description:
------------
PHP 8.1.0RC2 build downloaded from windows.php.net  missing php_oci8_12c.dll in the ext folder.



Test script:
---------------
Enable extension=oci8_12c  ; Use with Oracle Database 12c Instant Client

Expected result:
----------------
php -v starts php without error

Actual result:
--------------
PHP starts with this error:
The procedure entry point zend_parse_arg_str_or_long_slow@@24 could not be located in the dynamic link library c:\php80\ext\php_oci8_12c.dll

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-09-22 16:29 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-09-22 16:29 UTC] cmb@php.net
As of PHP 8.0.0, php_oci8_12c.dll is longer shipped in favor of
php_oci8_19.dll; that version is supposed to be compatible with
OCI8 12 and up.  If you need php_oci8_12c.dll for whatever reason,
you can get it from PECL[1], but note that versions for PHP 8.1
will only be made available after PHP 8.1.0 has been released.

[1] <https://pecl.php.net/package/oci8>
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 01:05:44 2022 UTC