php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81291 Issue tracker: "Please enable cookies so the Captcha system can work" error
Submitted: 2021-07-25 14:06 UTC Modified: 2022-01-06 13:14 UTC
From: chealer at gmail dot com Assigned:
Status: Open Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2021-07-25 14:06 UTC] chealer at gmail dot com
Description:
------------
Yesterday, I wrote an issue report on bugs.php.net. Before submitting bug #81290, I went to bed so I could review the report after a break and notice errors or omissions.

When I activated the "Send bug report" button today, I got the following error in a red rectangle at the top:
ERROR:
    Please enable cookies so the Captcha system can work

Obviously, cookies were enabled, so I could not do that. All I could do was to try submitting again, which worked.

I filed multiple other tickets without experiencing this problem, and if you read this, that is because filing this one will not have reproduced the problem. I can only guess this error is related to the longer-than-average time I took to submit the form.

By the way, "CAPTCHA" is an acronym and should be uppercase.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-09-29 16:33 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2021-09-29 16:33 UTC] cmb@php.net
This is a duplicate of bug #66653.
 [2021-09-30 12:45 UTC] chealer at gmail dot com
Are you sure Christoph? Ticket #66653 is about "Incorrect CAPTCHA" errors.
 [2021-09-30 12:53 UTC] cmb@php.net
-Status: Duplicate +Status: Open -Assigned To: cmb +Assigned To:
 [2021-09-30 12:53 UTC] cmb@php.net
Ah, right, this is a different issue:

> […] I went to bed so I could review the report after a break and
> notice errors or omissions.

So apparently the session had been garbage collected, and you've
got the confusing error message[1].  I think the message could be
improved to something that says "Invalid session …".  Maybe you
want to provide a pull request[2]?

[1] <https://github.com/php/web-bugs/blob/860d1552b51c21531083297f160db938f1a3e945/www/bug.php#L77-L78>
[2] <https://github.com/php/web-bugs/pulls>
 [2022-01-06 01:39 UTC] chealer at gmail dot com
Thanks Christoph

"Invalid session …" may be less bad than the current message, but I don't think it would be correct. I suppose "Session not found" would be better.

If by "provide a pull request" you mean submit a patch, I prefer to let maintainers decide which solution(s) they prefer. Fixing the wording is probably a good thing, but if this happens in less than 24 hours, other solutions should be considered (prolonging or eliminating sessions, or just eliminating the CAPTCHA).
 [2022-01-06 13:14 UTC] cmb@php.net
I wouldn't invest further time in this legacy bug tracker, since
we migrated to Github issues[1] a while ago.

[1] <https://wiki.php.net/rfc/github_issues>
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Sep 30 02:03:44 2022 UTC