php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81253 unexpected result of setting env[LC_MESSAGES] in php-fpm pool config
Submitted: 2021-07-12 17:08 UTC Modified: 2021-11-28 20:44 UTC
From: php at wb9 dot se Assigned: bukka (profile)
Status: Duplicate Package: FPM related
PHP Version: 7.4.21 OS: FreeBSD
Private report: No CVE-ID: None
 [2021-07-12 17:08 UTC] php at wb9 dot se
Description:
------------
Tested on FreeBSD 13 with PHP Version 7.4.21 from ports.

Configure line:  './configure' '--with-layout=GNU' '--with-config-file-scan-dir=/usr/local/etc/php' '--disable-all' '--with-libxml' '--with-password-argon2=/usr/local' '--program-prefix=' '--enable-mysqlnd' '--enable-fpm' '--with-fpm-user=www' '--with-fpm-group=www' '--enable-embed' '--enable-dtrace' '--prefix=/usr/local' '--localstatedir=/var' '--mandir=/usr/local/man' '--infodir=/usr/local/share/info/' '--build=amd64-portbld-freebsd13.0' 'build_alias=amd64-portbld-freebsd13.0' 'PKG_CONFIG=pkgconf' 'CFLAGS=-O2 -pipe -fstack-protector-strong -fno-strict-aliasing ' 'CPP=cpp' 'CXXFLAGS=-O2 -pipe -fstack-protector-strong -fno-strict-aliasing ' 

Setting env[LC_MESSAGES] = C.UTF-8 in the www php-fpm pool config sets results in "6" => "C.UTF8" in the $_SERVER array.

Test script:
---------------
phpinfo();

Expected result:
----------------
$_SERVER["LC_MESSAGES"] => "C.UTF-8"

Actual result:
--------------
$_SERVER["6"] => "C.UTF8"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-08-01 06:48 UTC] dc dot link at yahoo dot fr
Is this bug occuring with PHP 8 ?
 [2021-11-28 20:44 UTC] bukka@php.net
-Status: Open +Status: Duplicate
 [2021-11-28 20:44 UTC] bukka@php.net
This is because the environment variables are not currently supported in the FPM configuration. This is a duplicate of https://bugs.php.net/bug.php?id=76798
 [2021-11-28 20:44 UTC] bukka@php.net
-Assigned To: +Assigned To: bukka
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 04:03:40 2021 UTC