php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #81246 Issue tracker: Unclear description for status "Suspended"
Submitted: 2021-07-11 14:12 UTC Modified: 2022-01-20 17:22 UTC
From: chealer at gmail dot com Assigned: cmb (profile)
Status: Wont fix Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2021-07-11 14:12 UTC] chealer at gmail dot com
Description:
------------
https://bugs.php.net/search-howto.php offers the following explanation for status Suspended:
> Suspended: Tickets which are waiting on some action which is outside the scope of the PHP developers.

As the meaning of "the scope of the PHP developers" is critical to that definition, it would be important to clarify it by specifying all cases which are either inside or outside that scope.

Ticket #77403 might offer some useful background to help determine this.

Test script:
---------------
This does not report a behavioural bug.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-07-11 14:50 UTC] tiffany@php.net
Can you clarify what your expectation for resolving this is?

If you're expecting someone to go through all suspended bugs and document the reasons they were closed to provide as a list of cases, that isn't going to happen.
 [2021-07-11 14:51 UTC] tiffany@php.net
Unless you wish to volunteer yourself, and open a PR.
 [2021-07-11 14:54 UTC] tiffany@php.net
-Status: Open +Status: Feedback
 [2021-07-18 14:36 UTC] chealer at gmail dot com
-Status: Feedback +Status: Open
 [2021-07-18 14:36 UTC] chealer at gmail dot com
Tiffany, this ticket is an issue report about the description of the status named "Suspended". This is *not* a request to go through any other "bugs" and do anything about them - unless, of course, solving this would entail changing that status.

I do not know what you mean by "PR", but I cannot solve this by myself. I can tell that the current description is unclear, but I do not know what its author meant or what it should read.

That being said, I could see 2 avenues to solve this:
1. Add a link on "the scope of the PHP developers" bringing to a document defining what "the scope of the PHP developers" is
2. Augment the description so that readers do not need to know about "the scope of the PHP developers". As mentioned in the Description, this can be done by "specifying all cases which are either inside or outside that scope" (or both).
 [2021-09-24 00:46 UTC] ddpm at liscovius dot de
The problem with the select status of bug is that it mixes several properties into a single select.

For instance a bug can be a duplicate of some other bug, but could be open/closed too.

Or a bug is open, verified and someone is assigned to it, but has nothing done with it for several years, so it is calculated stale.

The priority of a bug could be normal, critical or suspended.
 [2022-01-20 17:22 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: cmb
 [2022-01-20 17:22 UTC] cmb@php.net
Given that bugsnet has been superseded by GH issues, it is
sufficiently safe to assume that this issue won't be fixed.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Sep 28 06:05:53 2022 UTC