php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81236 Arbitrary loss of last char in rtrim result
Submitted: 2021-07-08 15:03 UTC Modified: 2021-07-08 15:07 UTC
From: dev at solon dot media Assigned: cmb (profile)
Status: Not a bug Package: Strings related
PHP Version: 7.3.29 OS: RHEL
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
20 - 17 = ?
Subscribe to this entry?

 
 [2021-07-08 15:03 UTC] dev at solon dot media
Description:
------------
rtrim under odd circumstances returns a truncated string.

Test script:
---------------
<?php
$str = "performance-details";
echo rtrim($str,"-details");
?>

Expected result:
----------------
Should return 'performance'

Actual result:
--------------
Returns 'performanc' - the final e is dropped.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-07-08 15:07 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-07-08 15:07 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.
 [2021-07-08 15:13 UTC] danack@php.net
"Simply list all characters that you want to be stripped."

e is in the list.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jul 03 17:05:45 2022 UTC