php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81170 php.ini is not created
Submitted: 2021-06-19 01:29 UTC Modified: 2021-06-19 06:25 UTC
From: purityboy83 at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 8.0.7 OS: Oracle Linux 8.3
Private report: No CVE-ID: None
 [2021-06-19 01:29 UTC] purityboy83 at gmail dot com
Description:
------------
Hi

I compiled install because using aarch64(arm). The compiled version is 8.0.7.


PHP 8.0.7 (cli) (built: Jun 19 2021 09:46:40) ( NTS )
Copyright (c) The PHP Group
Zend Engine v4.0.7, Copyright (c) Zend Technologies

after compilation (make && make install), I looked for it, but there was no /etc/php.ini file


I have it set like this when configuring
./configure --prefix=/usr/local/php-8.0.7 \
--with-config-file-path=/etc \
--....
--....

but, php.ini is not created 

Compiled several times, but the same

Thanks



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-06-19 06:25 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2021-06-19 06:25 UTC] requinix@php.net
php.ini is not created for you, and without one PHP will use defaults for all settings. Copy php.ini-development or -production and configure as you want.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 28 17:05:46 2022 UTC