php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81133 opcache build fails because BUILD_CC is not defined in phpize builds
Submitted: 2021-06-13 10:47 UTC Modified: 2021-06-14 04:37 UTC
From: php-bugs-2021 at ryandesign dot com Assigned: krakjoe (profile)
Status: Closed Package: Compile Failure
PHP Version: 8.1.0alpha1 OS: macOS 10.13.6
Private report: No CVE-ID: None
 [2021-06-13 10:47 UTC] php-bugs-2021 at ryandesign dot com
Description:
------------
Hi, after applying the fix for bug #81130 I'm able to build php 8.1.0alpha1 and most of the extensions (standalone using phpize) on macOS but building the opcache extension this way fails:


/path/to/php-8.1.0alpha1/ext/opcache/jit/dynasm/minilua.c -lm -o minilua
make: /path/to/php-8.1.0alpha1/ext/opcache/jit/dynasm/minilua.c: Permission denied
make: *** [minilua] Error 1


It's trying to execute a non-executable (C source) file which of course doesn't work.

Looking at the Makefile, I see that what it is actually trying to do is compile it, using the variable $(BUILD_CC) which it expects to contain the compiler, but nothing has arranged for this variable to contain anything, so it is empty.

php 8.0.x and earlier didn't have this problem.

Presumably this was caused by f1ad9199eff32dd805bb5b155002bdb6ca69bf01. If I revert the part of that commit that affected ext/opcache/jit/Makefile.frag (if I change $(BUILD_CC) back to $(CC) in that file) then the build gets past this error, though I suspect that is not the solution you will want to use.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-06-13 10:58 UTC] krakjoe@php.net
-Assigned To: +Assigned To: krakjoe
 [2021-06-13 11:40 UTC] krakjoe@php.net
-Status: Assigned +Status: Feedback
 [2021-06-13 11:40 UTC] krakjoe@php.net
Check https://github.com/php/php-src/pull/7145 please
 [2021-06-13 14:29 UTC] krakjoe@php.net
-Status: Feedback +Status: Closed
 [2021-06-13 14:29 UTC] krakjoe@php.net
The fix for this bug has been committed.
If you are still experiencing this bug, try to check out latest source from https://github.com/php/php-src and re-test.
Thank you for the report, and for helping us make PHP better.

Fixed in edc0d76a9d2f9a9e14630efdabacf09dd37a9609
 [2021-06-14 04:37 UTC] php-bugs-2021 at ryandesign dot com
Thanks, that works!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 09:03:14 2021 UTC