php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #8108 implement trans-sid as output handler
Submitted: 2000-12-05 02:04 UTC Modified: 2012-03-31 06:35 UTC
Votes:8
Avg. Score:4.5 ± 1.3
Reproduced:6 of 7 (85.7%)
Same Version:6 (100.0%)
Same OS:6 (100.0%)
From: phpbug at jbirch dot com Assigned:
Status: Wont fix Package: Session related
PHP Version: 4.0.3pl1 OS: Free BSD 2.2.7
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2000-12-05 02:04 UTC] phpbug at jbirch dot com
I've got php4.3.3pl1 compiled as a CGI with --enable-trans-sid.

I currently use the ob_length function to send a Content-Length header with my semi-static pages to enhance their cacheability.  As soon as I enabled trans-sid with cookies disabled this behaviour broke, because ob_length appears to be calculated before the SID is applied to the page.  My pages get truncated by browsers that accept the content-length header (all modern browsers).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-11 09:45 UTC] stas@php.net
Actually, I guess trans-sid should be implemented as
output-buffering filter, just as gz-compression. Otherwise
what you are trying to do would never work.
 [2000-12-11 11:42 UTC] phpbug at jbirch dot com
I've been thinking about this a bit more.  I'm not sure if adding the ability to obtain the correct length of the buffered output in this case is more important than retailing the ability to save a non-user-specific version of the output.  

"Fixing" my problem would mean that a page caching system that writes plain .html files from database using the ob_ functions would be broken.

Would it be possible to add a function that performs the same function as trans-sid, but at a script level?  With this in place, I could turn off trans-sid and manipulate the output buffer directly.

A generic ob_filter() facility could come in handy for other things too, such as highlighing search terms in a page request.  Especially if it had a switch to filter the HTML, the marked up text, or both.

 [2001-02-19 23:50 UTC] andre@php.net
a) the ob_filter() part is not needed, because output
buffers are nestable
b) would be fine to have ob_transsid or similar, much more
flexible

moving to feature requests
 [2010-11-19 00:17 UTC] jani@php.net
-Package: Feature/Change Request +Package: Session related
 [2012-03-31 06:35 UTC] yohgaki@php.net
-Status: Analyzed +Status: Wont fix
 [2012-03-31 06:35 UTC] yohgaki@php.net
Trans SID is becoming as a legacy feature now. I suppose nobody is going to 
implement this.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 04:01:24 2020 UTC