php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81063 Memcached::setMulti() throws confusing TypeError
Submitted: 2021-05-20 22:18 UTC Modified: 2021-06-09 11:57 UTC
From: corey dot taylor dot fl at gmail dot com Assigned: cmb (profile)
Status: Closed Package: memcached (PECL)
PHP Version: Next Minor Version OS:
Private report: No CVE-ID: None
 [2021-05-20 22:18 UTC] corey dot taylor dot fl at gmail dot com
Description:
------------
Memcached::setMulti() expects an int expiration as the second parameter.

However, even though we pass an int, it generates a TypeError with a confusing message basically saying the type is correct:

TypeError: Memcached::setMulti(): Argument #2 ($expiration) must be of type int, int given

I don't know if this is a generic error that already exists in 8.1 or something specific to Memcached, but we aren't seeing it in many other places.

This is from 8.1/master at 7358457aa72acf10dd201970aecd1b1154b3ea0e.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-05-20 22:25 UTC] corey dot taylor dot fl at gmail dot com
-PHP Version: Next Major Version +PHP Version: Next Minor Version
 [2021-05-20 22:25 UTC] corey dot taylor dot fl at gmail dot com
Accidentally selected "Next Major Version"
 [2021-06-09 11:57 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2021-06-09 11:57 UTC] cmb@php.net
The memcached bug tracker is now on Github[1].  If this is still
an issue with the current memcached version, please report there.

[1] <https://github.com/php-memcached-dev/php-memcached/issues>
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 21 06:01:35 2024 UTC