php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81057 PHP-FPM: how to tell apache where is configuration file
Submitted: 2021-05-19 20:59 UTC Modified: 2021-05-20 00:13 UTC
From: gilperon at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 8.0.6 OS: ALL
Private report: No CVE-ID: None
 [2021-05-19 20:59 UTC] gilperon at gmail dot com
Description:
------------
I made a clean Centos 8 installation where I installed Apache 2.4 and php-fpm (remi-8.0) with this simple line:

dnf install -y httpd php-fpm

No other code, no other change to the server, nothing.

After starting httpd.service and php-fpm I can access PHP files using my browser. Great. The problem is this: I know that the configuration file of PHP-FPM is at /etc/php-fpm.d/www.conf but I have absolutely no idea how Apache is loading this file. On /etc/httpd/conf/httpd.conf I see nothing pointing to this file, same in the conf.modules.d directory - nothing.

I just want to know how does PHP tell Apache where to look for its configuration file ("/etc/php-fpm.d/www.conf")? In many tutorials online people installing php-fpm add lots of lines to virtual hosts, to httpd.conf file... But I did nothing and it worked. 

I already reported this on StackOverflow and was told to ask this here.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-05-19 21:06 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2021-05-19 21:06 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Sorry that someone pointed you to this bug tracker, but you don't have a bug tracker question.
 [2021-05-20 00:13 UTC] gilperon at gmail dot com
Sorry, would you mind closing this?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 27 13:06:06 2022 UTC