php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81020 Missing arginfo
Submitted: 2021-05-08 12:10 UTC Modified: 2021-06-11 16:36 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: php at ohreally dot nl Assigned:
Status: Not a bug Package: imagick (PECL)
PHP Version: 8.0.6 OS: FreeBSD
Private report: No CVE-ID: None
 [2021-05-08 12:10 UTC] php at ohreally dot nl
Description:
------------
Hi,

When I restart PHP-FPM, I get these warnings:

Starting php_fpm.
<br />
<b>Warning</b>:  Missing arginfo for Imagick::__tostring() in <b>Unknown</b> on line <b>0</b><br />
<br />
<b>Warning</b>:  Missing arginfo for Imagick::getimagehistogram() in <b>Unknown</b> on line <b>0</b><br />

In PHP8, arginfo is mandatory. Please see https://github.com/php/php-src/blob/PHP-8.0/UPGRADING.INTERNALS (1m: "All internal functions and methods are now required to specify arginfo information, otherwise warnings will be thrown on startup.").

Cheers,
  Rob


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-06-11 16:36 UTC] danack@php.net
-Status: Open +Status: Not a bug
 [2021-06-11 16:36 UTC] danack@php.net
You aren't using an official release of Imagick. I'm not sure where you got it from, but the release of Imagick for PHP 8, that is imminent, won't have this problem.
 [2021-06-11 18:37 UTC] php at ohreally dot nl
Hi,

Sorry to have wasted your time.
I have reported this to the maintainer for the FreeBSD port: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256557

Cheers,
  Rob
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jul 26 00:01:24 2021 UTC