php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80943 pow and ** different result
Submitted: 2021-04-08 23:17 UTC Modified: 2021-04-08 23:31 UTC
From: inpostdpua at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 8.0.3 OS: all
Private report: No CVE-ID: None
 [2021-04-08 23:17 UTC] inpostdpua at gmail dot com
Description:
------------
echo pow(-3, 3.5); // NAN
echo "\r\n";
echo -3**3.5; // -46.76537180436

As i think, it`s must be same result.

Test script:
---------------
echo pow(-3, 3.5);
echo "\r\n";
echo -3**3.5;


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-04-08 23:31 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2021-04-08 23:31 UTC] requinix@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

https://www.php.net/manual/en/language.operators.precedence.php
** has higher precedence than -. Use parentheses like (-3)**3.5.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 21:03:42 2022 UTC