|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80733 pecl install memcache fails telling me it needs PHP 8
Submitted: 2021-02-11 17:52 UTC Modified: 2021-03-25 16:43 UTC
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: jon at senyahnoj dot org dot uk Assigned: cmb (profile)
Status: Not a bug Package: memcache (PECL)
PHP Version: 7.4.15 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
39 - 21 = ?
Subscribe to this entry?

 [2021-02-11 17:52 UTC] jon at senyahnoj dot org dot uk
Run the following command (as root)

pecl install memcache

It fails with the following output:

pecl/memcache requires PHP (version >= 8.0.0), installed version is 7.4.15
No valid packages found
install failed

Test script:
pecl install memcache

Expected result:
I would expect the pecl memcache extension to install for this particular version of PHP.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2021-03-25 16:43 UTC]
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-03-25 16:43 UTC]
You need to explicitly specify the version; from the changelog:
- Version 8.x support PHP 8.x
- Version 4.x supports PHP 7.0-7.4.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Mar 22 20:03:59 2023 UTC