php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80733 pecl install memcache fails telling me it needs PHP 8
Submitted: 2021-02-11 17:52 UTC Modified: 2021-03-25 16:43 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: jon at senyahnoj dot org dot uk Assigned: cmb (profile)
Status: Not a bug Package: memcache (PECL)
PHP Version: 7.4.15 OS: Linux
Private report: No CVE-ID: None
 [2021-02-11 17:52 UTC] jon at senyahnoj dot org dot uk
Description:
------------
Run the following command (as root)

pecl install memcache

It fails with the following output:

pecl/memcache requires PHP (version >= 8.0.0), installed version is 7.4.15
No valid packages found
install failed


Test script:
---------------
pecl install memcache

Expected result:
----------------
I would expect the pecl memcache extension to install for this particular version of PHP.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-03-25 16:43 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-03-25 16:43 UTC] cmb@php.net
You need to explicitly specify the version; from the changelog:
- Version 8.x support PHP 8.x
- Version 4.x supports PHP 7.0-7.4.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Apr 19 12:01:23 2021 UTC