|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80733 pecl install memcache fails telling me it needs PHP 8
Submitted: 2021-02-11 17:52 UTC Modified: 2021-03-25 16:43 UTC
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: jon at senyahnoj dot org dot uk Assigned: cmb (profile)
Status: Not a bug Package: memcache (PECL)
PHP Version: 7.4.15 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: jon at senyahnoj dot org dot uk
New email:
PHP Version: OS:


 [2021-02-11 17:52 UTC] jon at senyahnoj dot org dot uk
Run the following command (as root)

pecl install memcache

It fails with the following output:

pecl/memcache requires PHP (version >= 8.0.0), installed version is 7.4.15
No valid packages found
install failed

Test script:
pecl install memcache

Expected result:
I would expect the pecl memcache extension to install for this particular version of PHP.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2021-03-25 16:43 UTC]
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-03-25 16:43 UTC]
You need to explicitly specify the version; from the changelog:
- Version 8.x support PHP 8.x
- Version 4.x supports PHP 7.0-7.4.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 16 01:01:28 2024 UTC