|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80607 Cannot install via Pecl in PHP 8.0.1 due to unsupported 'asm goto'
Submitted: 2021-01-08 17:24 UTC Modified: -
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: seb at seblog dot nl Assigned:
Status: Open Package: PECL (PECL)
PHP Version: 8.0.1 OS: macOS 10.15.7
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: seb at seblog dot nl
New email:
PHP Version: OS:


 [2021-01-08 17:24 UTC] seb at seblog dot nl
First off: I have no idea what I am doing. Sorry about that. I'm trying to be helpful.

I tried installing the phpredis extension for PHP 8.0.1 via PECL (but tried to install swoole too, to pinpoint the error: that had the same issue, so I think it's PECL itself).

The installation ends with the error: "'asm goto' constructs are not supported" for the file `php/8.0.1/include/php/Zend/zend_operators.h` on locations 541:10, 604:10, 674:10 and 784:10.

When I look at Github for a blame of that file, I come across this commit for 8.0.1:

And when I, not held back by any knowledge of things, change the `1` in `# define ZEND_USE_ASM_ARITHMETIC 1` on line 512 to `0`... I seems to turn off the use of `goto` stuff, so the installation succeeds and now I can use the Redis class again.

... so, my problem is 'solved', but there is something not right. I'm happy to provide additional information, if that is useful.

Thanks for making PHP!


Add a Patch

Pull Requests

Add a Pull Request

PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Apr 11 16:01:23 2021 UTC