php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80607 Cannot install via Pecl in PHP 8.0.1 due to unsupported 'asm goto'
Submitted: 2021-01-08 17:24 UTC Modified: 2021-06-02 14:52 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: seb at seblog dot nl Assigned:
Status: Duplicate Package: PECL (PECL)
PHP Version: 8.0.1 OS: macOS 10.15.7
Private report: No CVE-ID: None
 [2021-01-08 17:24 UTC] seb at seblog dot nl
Description:
------------
First off: I have no idea what I am doing. Sorry about that. I'm trying to be helpful.

I tried installing the phpredis extension for PHP 8.0.1 via PECL (but tried to install swoole too, to pinpoint the error: that had the same issue, so I think it's PECL itself).

The installation ends with the error: "'asm goto' constructs are not supported" for the file `php/8.0.1/include/php/Zend/zend_operators.h` on locations 541:10, 604:10, 674:10 and 784:10.

When I look at Github for a blame of that file, I come across this commit for 8.0.1:
https://github.com/php/php-src/commit/33bf1495b215d555d45ec638376bd434d8a038b3

And when I, not held back by any knowledge of things, change the `1` in `# define ZEND_USE_ASM_ARITHMETIC 1` on line 512 to `0`... I seems to turn off the use of `goto` stuff, so the installation succeeds and now I can use the Redis class again.

... so, my problem is 'solved', but there is something not right. I'm happy to provide additional information, if that is useful.

Thanks for making PHP!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-06-02 14:52 UTC] derick@php.net
-Status: Open +Status: Duplicate
 [2021-06-02 14:52 UTC] derick@php.net
Duplicate of #75951
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 15:03:37 2021 UTC