php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80565 strip_tags altering allow tags attributes
Submitted: 2020-12-30 21:29 UTC Modified: 2020-12-30 22:12 UTC
From: roberto dot diana at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: *General Issues
PHP Version: master-Git-2020-12-30 (Git) OS:
Private report: No CVE-ID: None
 [2020-12-30 21:29 UTC] roberto dot diana at gmail dot com
Description:
------------
Basic test example
https://3v4l.org/4Yaoj


Test script:
---------------
<?php
echo strip_tags('<tag alt="xx> xx<">', '<tag>') . PHP_EOL;


Expected result:
----------------
<tag alt="xx> xx<">


Actual result:
--------------
<tag alt="xx xx">

Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-12-30 21:33 UTC] roberto dot diana at gmail dot com
The following pull request has been associated:

Patch Name: Adds test and fix to bug 74371 but for php8
On GitHub:  https://github.com/php/php-src/pull/6492
Patch:      https://github.com/php/php-src/pull/6492.patch
 [2020-12-30 21:37 UTC] roberto dot diana at gmail dot com
related bug ticket 
https://bugs.php.net/bug.php?id=74371
 [2020-12-30 22:12 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2020-12-30 22:12 UTC] cmb@php.net
Duplicate of bug #74371.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Sep 21 04:03:38 2021 UTC