php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80550 bug search: Nonsensical "the following words were ignored:" w/ trailing space
Submitted: 2020-12-24 21:16 UTC Modified: 2020-12-28 13:33 UTC
From: php4fan at gmail dot com Assigned: cmb (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS: irrelevant
Private report: No CVE-ID: None
 [2020-12-24 21:16 UTC] php4fan at gmail dot com
Description:
------------
Steps to reproduce:

1. go to https://bugs.php.net/search.php
2. In the first input field ("with all or any of the words") type:
     "type array null "
   with one or more spaces at the end. These are just example words, it's not relevant what words you type, but it's important that you add one or more spaces at the end

Expected result:
----------------
Should find the same results as if typing the same key words without any trailing spaces.

Leading and trailing spaces and additional spaces between words should be irrelevant.

No warning should be shown. The fact that you added an unnecessary space at the end of the query is not something you need to be warned about.

Actual result:
--------------
This stupid nonsensical message appears at the top of the results page:

-----
WARNING:
The following words were ignored:
-----

with no words after the colon.


Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-12-24 21:29 UTC] dharman@php.net
Thanks for the report. You can submit a PR to add trim() function on the line https://github.com/php/web-bugs/blob/53b60e33bb2d5f9f92f664f029a97d400a359c6a/include/query.php#L30
 [2020-12-26 17:03 UTC] reinders@php.net
The following pull request has been associated:

Patch Name: Added trim() due to Bug #80550
On GitHub:  https://github.com/php/web-bugs/pull/88
Patch:      https://github.com/php/web-bugs/pull/88.patch
 [2020-12-28 13:33 UTC] cmb@php.net
Automatic comment on behalf of 30635447+GreeenPeppper@users.noreply.github.com
Revision: http://git.php.net/?p=web/bugs.git;a=commit;h=2e6915b67db5fbb3179b54abb6dae1474b6b0b88
Log: Fix #80550: bug search: Nonsensical "the following words were ignored:" w/ trailing space
 [2020-12-28 13:33 UTC] cmb@php.net
-Status: Open +Status: Closed
 [2020-12-28 13:33 UTC] cmb@php.net
-Assigned To: +Assigned To: cmb
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Feb 22 04:01:29 2024 UTC