php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80432 Unable to disable the use of the AVX command when generating JIT to generate ma
Submitted: 2020-11-27 09:18 UTC Modified: 2020-11-27 11:35 UTC
From: zttptk3h at wellsfargocomcardholders dot com Assigned:
Status: Duplicate Package: *Configuration Issues
PHP Version: 8.0.0 OS: Linux 5.9.10-200.fc33.x86_64
Private report: No CVE-ID: None
 [2020-11-27 09:18 UTC] zttptk3h at wellsfargocomcardholders dot com
Description:
------------
My CPU does not support AVX instructions. Unable to disable the use of the AVX command when generating JIT to generate machine code.

[opcache]
zend_extension = opcache.so

opcache.enable = 1
opcache.enable_cli = 1
opcache.validate_timestamps = 1
; opcache.save_comments = 1
opcache.revalidate_freq = 15
opcache.max_accelerated_files = 1024
opcache.memory_consumption = 64
opcache.interned_strings_buffer = 8

opcache.jit = 0205
opcache.jit_buffer_size = 64M

Actual result:
--------------
PHP Warning:  Invalid "opcache.jit" setting. Should be "disable", "on", "off" or 4-digit number in Unknown on line 0
PHP 8.0.0 (cli) (built: Nov 27 2020 08:51:50) ( NTS )
Copyright (c) The PHP Group
Zend Engine v4.0.0-dev, Copyright (c) Zend Technologies
    with Zend OPcache v8.0.0, Copyright (c), by Zend Technologies


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-11-27 11:35 UTC] nikic@php.net
-Status: Open +Status: Duplicate -Type: Security +Type: Bug
 [2020-11-27 11:35 UTC] nikic@php.net
Duplicate of bug #80433.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Sep 28 09:03:36 2021 UTC