php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80418 pecl install mongodb dumps core at end
Submitted: 2020-11-25 15:11 UTC Modified: 2021-02-15 13:26 UTC
From: jwoehr at softwoehr dot com Assigned: cmb (profile)
Status: Not a bug Package: mongodb (PECL)
PHP Version: 7.4.12 OS: Linux
Private report: No CVE-ID: None
 [2020-11-25 15:11 UTC] jwoehr at softwoehr dot com
Description:
------------
At the end of pecl install mongodb the install dumps core.
E.g., on Fedora 33 Server:
```
Build process completed successfully
Installing '/usr/lib64/php/modules/mongodb.so'
upgrade ok: channel://pecl.php.net/mongodb-1.9.0
configuration option "php_ini" is not set to php.ini location
You should add "extension=mongodb.so" to php.ini
Segmentation fault (core dumped)
```
The package is, however, correctly installed thereafter.
One of Mongodb architects says it comes from changing the .so when it has already been loaded by PHP.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-11-25 15:42 UTC] remi@php.net
Use the distribution package
https://bodhi.fedoraproject.org/updates/FEDORA-2020-50162549b6
 [2020-11-25 22:42 UTC] sixd@php.net
Also seen with OCI8 on Oracle Linux, presumably for the same reason.  The testcase was building PHP with OCI8 as a shared extension, then immediately doing 'pecl install oci8-3.0.0.tgz'.  This seg faulted.  Any later 'pecl uninstall oci8' followed with 'pecl install oci8-3.0.0.tgz' did not dump.
 [2020-11-25 23:26 UTC] cmb@php.net
To my knowledge, replacing a .so which is in use is supposed to
cause issues.  It may work to `rm` the .so first.  Anyway, this
likely should be reported against the PEAR bug tracker[1],
although I don't know whether this could be successful.  Probably
better to provide a PR to the PEAR repo[2].

[1] <https://pear.php.net/bugs/>
[2] <https://github.com/pear/pear-core>
 [2020-11-26 10:52 UTC] derick@php.net
FWIW, I see the same with Xdebug.
 [2021-02-15 13:26 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-02-15 13:26 UTC] cmb@php.net
This is not a PHP issue (see my comment above).
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 19:03:37 2021 UTC