php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #80408 Indicate more details about the error in question
Submitted: 2020-11-24 06:58 UTC Modified: 2020-11-24 14:16 UTC
From: valentin dot gratz at orange dot fr Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 8.0.0RC5 OS:
Private report: No CVE-ID: None
 [2020-11-24 06:58 UTC] valentin dot gratz at orange dot fr
Description:
------------
for version 8.0.0

proposal of features

When we test our php in localhost for example the upload with a file too large, it tells us that it could not download it, outside, it does not tell us what error it is, what is the parameters which are to be modified, not as in javascript which indicates it to us.

To sum up, be able to give more details on the error in order to better identify and correct oneself.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-11-24 13:22 UTC] requinix@php.net
-Status: Open +Status: Feedback
 [2020-11-24 13:22 UTC] requinix@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.


 [2020-11-24 14:13 UTC] valentin dot gratz at orange dot fr
-Status: Feedback +Status: Open
 [2020-11-24 14:13 UTC] valentin dot gratz at orange dot fr
How to propose an idea of improvement, if here it is only bugs?

Then, an example that I saw in training, when we are in localhost, and we want to upload a large file that exceeds the maximum size, on the browser, it does not tell us that the size has been exceeded. So I wanted to suggest the idea that there is an error message, like for example "the file size exceeds the maximum allowed size". For example.
 [2020-11-24 14:16 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2020-11-24 14:16 UTC] requinix@php.net
If you want to show an error message then you can show an error message. PHP gives you the information you need to know if and how something went wrong.
https://www.php.net/manual/en/features.file-upload.post-method.php
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 07:03:34 2021 UTC