php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80407 No way to specify location of argon2 lib. configure does not use pkg-conf for it
Submitted: 2020-11-23 20:03 UTC Modified: 2020-11-24 10:54 UTC
From: bugs-php dot a2 at x25 dot pl Assigned: cmb (profile)
Status: Not a bug Package: *Compile Issues
PHP Version: 7.4.12 OS:
Private report: No CVE-ID: None
 [2020-11-23 20:03 UTC] bugs-php dot a2 at x25 dot pl
Description:
------------
--with-password-argon2 enables argon2 support in configure but it does not use 
pkg-config for locating argon2 library. Also there is no other way to specify this location.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-11-23 20:04 UTC] bugs-php dot a2 at x25 dot pl
-Summary: No way to specify location of argon2 lib. Does configure does not use pkg-conf +Summary: No way to specify location of argon2 lib. configure does not use pkg-conf for it
 [2020-11-23 20:04 UTC] bugs-php dot a2 at x25 dot pl
-
 [2020-11-23 20:45 UTC] cmb@php.net
From the PHP manual[1]:

| To enable Argon2 password hashing, however, PHP must be build
| with libargon2 support using the --with-password-argon2[=DIR]
| configure option.

[1] <https://www.php.net/manual/en/password.installation.php>
 [2020-11-23 20:45 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-11-23 20:45 UTC] cmb@php.net
.
 [2020-11-24 10:54 UTC] nikic@php.net
We should still make argon2 use pkg-config for master at least ... done in https://github.com/php/php-src/commit/7965bc3656eff9753f45037b2d343017855591ee.

We originally tried to do this for 7.4 already, but pkg-config support was not good enough at that point, see discussion on https://github.com/php/php-src/commit/bdcef51bcb367323f2eea4808f34a1b3e58bd3d8.
 [2021-09-24 18:38 UTC] Danack at basereality dot com
Minus the extra dot - https://github.com/php/php-src/commit/bdcef51bcb367323f2eea4808f34a1b3e58bd3d8
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 06:03:41 2021 UTC