php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80365 Nonsensical error message says "expecting end of file"
Submitted: 2020-11-13 18:49 UTC Modified: 2021-02-05 21:44 UTC
From: php4fan at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: Scripting Engine problem
PHP Version: 8.0.0RC4 OS: all
Private report: No CVE-ID: None
 [2020-11-13 18:49 UTC] php4fan at gmail dot com
Description:
------------
The script below rightfully results in a parse error, but the error message is garbage.

It says 'unexpected token "<"' (so far so good) but then it adds "expecting end of file".

End of file is only one out of a pile of possible valid tokens there.

I appreciate that you tried to improve on previous versions which would only say "unexpected token [...]" without specifying what valid thing was expected. I myself complained many times about that. It's necessary to always specify not only the unexpected thing but also what was expected instead, at least when the range of possibilities can be reasonably narrowed down.

But it makes no sense to name only one random possible valid token and to say you are expecting that one. If the range of valid possibilities is too big to list, just say so.

Test script:
---------------
<?php

echo 3+2;
// I'll forget a closing php tag ("? >") now


<body>
</body>
<?php

// ...

?>

Expected result:
----------------
  
   Parse error: syntax error, unexpected token "<", ...

and there you could end with something like:

 "expecting end of file among other valid possibilities", 

or

 "expecting something else (too many possibilities to list them exhaustively)"


(and of course "on line 7")

Actual result:
--------------
Parse error: syntax error, unexpected token "<", expecting end of file in [...] on line 7

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-11-13 18:49 UTC] php4fan at gmail dot com
Similar issue:
https://bugs.php.net/bug.php?id=77101
 [2021-02-05 21:44 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Package: *General Issues +Package: Scripting Engine problem -Assigned To: +Assigned To: cmb
 [2021-02-05 21:44 UTC] cmb@php.net
Duplicate of feature request #47883.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Aug 01 23:01:24 2021 UTC