php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80306 The address operation does not pass correctly.
Submitted: 2020-11-02 15:22 UTC Modified: 2020-11-02 15:28 UTC
From: ynj0iub4 at powerencry dot com Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 7.4.12 OS: Linux
Private report: No CVE-ID: None
 [2020-11-02 15:22 UTC] ynj0iub4 at powerencry dot com
Description:
------------
The address operation does not pass correctly.

Test script:
---------------
<?php

$a = 10;
$b = 20;

$i = &$a;
$s = &$i;

$i = &$b; // ?

var_dump($s); // The output here should be 20.

Expected result:
----------------
20

Actual result:
--------------
10

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-11-02 15:28 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2020-11-02 15:28 UTC] requinix@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

https://www.php.net/manual/en/language.references.php
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 22 20:05:44 2022 UTC