php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80274 Simple addition and subtraction, but the result is messy.
Submitted: 2020-10-23 06:34 UTC Modified: 2020-10-23 06:36 UTC
From: 2007 dot liufeng dot love at gmail dot com Assigned:
Status: Not a bug Package: Math related
PHP Version: 7.3.23 OS: CentOS Linux release 7.8.2003 (C
Private report: No CVE-ID: None
 [2020-10-23 06:34 UTC] 2007 dot liufeng dot love at gmail dot com
Description:
------------
Simple addition and subtraction, but the result is messy.

Test script:
---------------
var_dump(1011.55 + 228.83 - 1240.38);

Expected result:
----------------
0

Actual result:
--------------
float(-2.2737367544323E-13)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-10-23 06:36 UTC] sjon@php.net
-Status: Open +Status: Not a bug
 [2020-10-23 06:36 UTC] sjon@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

See https://floating-point-gui.de/ for a longer explanation
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 07:01:24 2020 UTC