php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80263 PHP 7.2.27's SoapClient seems to be dropping returned elements with numerals
Submitted: 2020-10-20 15:19 UTC Modified: 2020-10-20 16:09 UTC
From: gnarlypowers+2020-10-20 at gmail dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 7.2.27 OS: CentOS
Private report: No CVE-ID: None
 [2020-10-20 15:19 UTC] gnarlypowers+2020-10-20 at gmail dot com
Description:
------------
Working with web-services provided by another system, I am able to use SoapClient to receive values for all but one element. Using __getLastResponse and then DOMDocument::loadXml I'm able to see the element being dropped by whatever parsing SoapClient is using. The element name in my case was "W9StatusICD".

Test script:
---------------
// Preconditions: $url defined as a WSDL with a method $method, which returns at least one element with a numeral in the name after the first character when called with $params (a numeral as the first character would be invalid XML)

try {
	$client = new SoapClient(
		$url,
		array(
			'trace' => 1,
			'exception' => 1
		)
	);
	return $client->$method($params);
	catch (Exception $e) {
		echo '<p class="error">'$e->getMessage(),'</p>';
	}
}

echo '<p><pre>',htmlspecialchars(print_r($client->__getLastResponse(),true)),'</pre></p>';

Expected result:
----------------
An element with a numeral in the second or later position in the name (example: W9StatusICD) should be indicated in the resulting text.

Actual result:
--------------
All elements except those with numerals are returned.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-10-20 15:30 UTC] gnarlypowers+2020-10-20 at gmail dot com
Please disregard. New data suggests this has nothing to do with the digit, and may be related to other parts of the system I'm working with
 [2020-10-20 15:32 UTC] gnarlypowers+2020-10-20 at gmail dot com
-Status: Open +Status: Closed -PHP Version: 7.2Git-2020-10-20 (Git) +PHP Version: 7.2.27
 [2020-10-20 15:32 UTC] gnarlypowers+2020-10-20 at gmail dot com
Closing
 [2020-10-20 16:09 UTC] cmb@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 19 16:03:35 2021 UTC