php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80254 Deprecated timezone designation: Kyiv not Kiev
Submitted: 2020-10-18 13:24 UTC Modified: 2020-10-18 21:55 UTC
From: valeriy dot drotenko at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: Irrelevant OS: Any
Private report: No CVE-ID: None
 [2020-10-18 13:24 UTC] valeriy dot drotenko at gmail dot com
Description:
------------
Ukrainian timezone name 'Europe/Kiev' should read 'Europe/Kyiv' effective October, 2nd, 2018.
Please refer to the official guidance from Ukrainian Foreign Affairs Ministry here: https://mfa.gov.ua/en/correctua
---
From manual page: https://php.net/timezones.europe
---
P.S. I'll submit diff later...



Patches

KyivNotKiev (last revision 2020-10-18 19:12 UTC by valeriy dot drotenko at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-10-18 13:54 UTC] nikic@php.net
-Status: Open +Status: Not a bug
 [2020-10-18 13:54 UTC] nikic@php.net
Timezone names are specified by IANA, please see https://www.iana.org/time-zones for more information and communication channels.
 [2020-10-18 19:12 UTC] valeriy dot drotenko at gmail dot com
The following patch has been added/updated:

Patch Name: KyivNotKiev
Revision:   1603048349
URL:        https://bugs.php.net/patch-display.php?bug=80254&patch=KyivNotKiev&revision=1603048349
 [2020-10-18 19:19 UTC] valeriy dot drotenko at gmail dot com
IANA is lagging behind, and we'll take care of them as well. The official name is Kyiv, and every authority is liable to adhere to that guidance. Two years have passed since its adoption - a time more than well sufficient to comply.
Meanwhile, other sources have already complied (e.g., in Microsoft Windows, as of the version 10, if you look into the Date & time settings => Time zone dropdown contains the following entry:
 '(UTC+02:00) Helsinki, Kyiv, Irga, Sofia, Tallinn, Vilnius'

Also, I've submitted a patch, so, hope, this change will be applied into one of the nearest releases.

Thanks a lot in advance and have a nice week!
 [2020-10-18 21:29 UTC] requinix@php.net
https://github.com/eggert/tz/commit/b2eede3d1b62c43d0121dd2f6e790b97f29da7b7

> Meanwhile, other sources have already complied (e.g., in Microsoft Windows,
Windows does not use IANA identifiers for their timezones.
 [2020-10-18 21:55 UTC] derick@php.net
This will only change in PHP if IANA changes it, and then automatically. If IANA doesn't change it, PHP won't either.
 [2021-04-07 09:44 UTC] gemnatu at gmail dot com
The Ukrainian cities listed in the timezones are using Russian spelling,
not Ukrainian spelling.

Kiev -> Kyiv
Uzhgorod -> Uzhhorod
Zaporozhye -> Zaporizhzhia

IANA and ICANN have been contacted. It would be helpful for PHP to reach out as developers as well. It is a problem because the spelling is a political statement for a lot of people/businesses. There is a war between Russian and Ukraine. By having these spellings listed through PHP.net, your company is also taking a political position.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 21 15:05:45 2022 UTC