php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80132 Error when running buildconf
Submitted: 2020-09-22 10:47 UTC Modified: 2020-10-02 08:06 UTC
From: m dot aldofirmansyah at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: *Configuration Issues
PHP Version: 8.0Git-2020-09-22 (Git) OS: Ubuntu 16.04.1
Private report: No CVE-ID: None
 [2020-09-22 10:47 UTC] m dot aldofirmansyah at gmail dot com
Description:
------------
Error when I'm trying to build php from source

I'm using ubuntu 16.04.1
php from master branch (seems it's php 8)
I have the latest version of autoconf, automake, and m4

buildconf: Checking installation
buildconf: autoconf version 2.69 (ok)
buildconf: Cleaning cache and configure files
buildconf: Rebuilding configure
/usr/bin/m4:configure.ac:6: cannot open `build/ax_check_compile_flag.m4': No such file or directory
/usr/bin/m4:configure.ac:7: cannot open `build/ax_func_which_gethostbyname_r.m4': No such file or directory
/usr/bin/m4:configure.ac:8: cannot open `build/ax_gcc_func_attribute.m4': No such file or directory
/usr/bin/m4:configure.ac:9: cannot open `build/libtool.m4': No such file or directory
/usr/bin/m4:configure.ac:10: cannot open `build/php_cxx_compile_stdcxx.m4': No such file or directory
/usr/bin/m4:configure.ac:11: cannot open `build/php.m4': No such file or directory
/usr/bin/m4:configure.ac:12: cannot open `build/pkg.m4': No such file or directory
sh: 1: ./build/config-stubs: not found
sh: 1: ./build/config-stubs: not found
autom4te: /usr/bin/m4 failed with exit status: 1
buildconf: Rebuilding main/php_config.h.in
/usr/bin/m4:configure.ac:6: cannot open `build/ax_check_compile_flag.m4': No such file or directory
/usr/bin/m4:configure.ac:7: cannot open `build/ax_func_which_gethostbyname_r.m4': No such file or directory
/usr/bin/m4:configure.ac:8: cannot open `build/ax_gcc_func_attribute.m4': No such file or directory
/usr/bin/m4:configure.ac:9: cannot open `build/libtool.m4': No such file or directory
/usr/bin/m4:configure.ac:10: cannot open `build/php_cxx_compile_stdcxx.m4': No such file or directory
/usr/bin/m4:configure.ac:11: cannot open `build/php.m4': No such file or directory
/usr/bin/m4:configure.ac:12: cannot open `build/pkg.m4': No such file or directory
sh: 1: ./build/config-stubs: not found
sh: 1: ./build/config-stubs: not found
autom4te: /usr/bin/m4 failed with exit status: 1
autoheader: '/usr/local/bin/autom4te' failed with exit status: 1
buildconf: Run ./configure to proceed with customizing the PHP build.

Test script:
---------------
./buildconf

Expected result:
----------------
able to build php successfully


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-09-22 10:54 UTC] nikic@php.net
> /usr/bin/m4:configure.ac:6: cannot open `build/ax_check_compile_flag.m4': No such file or directory

Do those files exist?
 [2020-09-22 11:15 UTC] m dot aldofirmansyah at gmail dot com
the m4 files in build folder doesn't exist
 [2020-09-22 11:23 UTC] cmb@php.net
> the m4 files in build folder doesn't exist

Seems you have a bad checkout.
 [2020-09-23 03:02 UTC] m dot aldofirmansyah at gmail dot com
Try to download and build php8 beta 4 on my vps ubuntu 16.04 it successfully running buildconf and configure

But when I run the same command on my docker 16.04 it still return same error
 [2020-09-23 07:54 UTC] nikic@php.net
Sounds like docker is stripping out your build/ directory then. Maybe it is ignored? (It's commonly used for build results, so I wouldn't be surprised...)
 [2020-10-01 14:50 UTC] nikic@php.net
-Status: Open +Status: Feedback
 [2020-10-02 04:04 UTC] m dot aldofirmansyah at gmail dot com
-Status: Feedback +Status: Open
 [2020-10-02 04:04 UTC] m dot aldofirmansyah at gmail dot com
Eventually I solved the issue by download and configure, then copy all configuration file to another directory, make and successfully installed
 [2020-10-02 08:06 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-10-02 08:06 UTC] cmb@php.net
Great that you have that resolved!  Doesn't look like a PHP bug,
though.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 21 16:03:35 2022 UTC