php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80106 Compilation failed with PHP 8
Submitted: 2020-09-14 13:55 UTC Modified: 2021-02-12 16:44 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:3 (100.0%)
Same OS:1 (33.3%)
From: mlocati at gmail dot com Assigned:
Status: Closed Package: gmagick (PECL)
PHP Version: 8.0.0beta3 OS: Ubuntu
Private report: No CVE-ID: None
 [2020-09-14 13:55 UTC] mlocati at gmail dot com
Description:
------------
It's not possible to compile gmagick for PHP8.

I have a bunch of errors like:

php_gmagick_helpers.h:43:69: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’

void *get_pointinfo_array(zval *coordinate_array, int *num_elements TSRMLS_DC);


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-09-14 14:17 UTC] cmb@php.net
These TSRM* macros are removed as of PHP 8.0.0, and are not necessary anymore as of PHP 7.0.0, so yes, gmagick needs to be updated.
 [2020-12-02 09:31 UTC] shop1 at mokraemer dot de
Still valid. Will there be a release soon?
 [2021-02-12 16:44 UTC] mlocati at gmail dot com
-Status: Open +Status: Closed
 [2021-02-12 16:44 UTC] mlocati at gmail dot com
We have a new version on PECL that works with PHP 8.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Oct 23 02:03:34 2021 UTC