php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80104 PHP8 comparison greater than results in true for non-numeric string
Submitted: 2020-09-14 13:43 UTC Modified: 2020-09-14 13:48 UTC
From: gielwijgergangs at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 8.0.0beta3 OS: any
Private report: No CVE-ID: None
 [2020-09-14 13:43 UTC] gielwijgergangs at gmail dot com
Description:
------------
PHP8 comparison results in true where previous php versions do not


Check script at:
https://3v4l.org/lsJkL

The result is the same when $val = 'someprefix';

Not sure whether this is a bug of intended in php8!? 

Test script:
---------------
<?php

$val = 'someprefix3333';

if($val > 0){
    echo $val . ' is greater than 0';
}
else {
    echo $val . ' is NOT greater than 0';
}

Expected result:
----------------
someprefix3333 is NOT greater than 0

Actual result:
--------------
someprefix3333 is greater than 0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-09-14 13:48 UTC] derick@php.net
-Status: Open +Status: Not a bug
 [2020-09-14 13:48 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

See https://wiki.php.net/rfc/saner-numeric-strings
And hear: https://phpinternals.news/62
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 23:05:51 2022 UTC