php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80005 Unable to load dynamic library .... undefined symbol
Submitted: 2020-08-21 13:46 UTC Modified: 2020-08-21 13:54 UTC
From: rentech at mail dot ru Assigned: cmb (profile)
Status: Not a bug Package: Dynamic loading
PHP Version: 7.2.33 OS: CentOS 8.2
Private report: No CVE-ID: None
 [2020-08-21 13:46 UTC] rentech at mail dot ru
Description:
------------
Apache HTTPD 2.4.46, OpenSSL/1.1.1c, PHP compiled by rpmbuild from spec file.

After httpd -k start following error message appears in Apache log file:

[Fri Aug 21 14:25:41.532381 2020] [ssl:info] [pid 496549:tid 139767625967488] AH01887: Init: Initializing (virtual) servers for SSL
[Fri Aug 21 14:25:41.537378 2020] [ssl:info] [pid 496549:tid 139767625967488] AH01876: mod_ssl/2.4.46 compiled against Server: Apache/2.4.46, Library: OpenSSL/1.1.1c
[Fri Aug 21 14:25:41.556331 2020] [socache_shmcb:info] [pid 496550:tid 139767625967488] AH00830: Shared memory socache initialised
[Fri Aug 21 14:25:41.556377 2020] [ssl:info] [pid 496550:tid 139767625967488] AH01887: Init: Initializing (virtual) servers for SSL
[Fri Aug 21 14:25:41.560569 2020] [ssl:info] [pid 496550:tid 139767625967488] AH01876: mod_ssl/2.4.46 compiled against Server: Apache/2.4.46, Library: OpenSSL/1.1.1c
PHP Warning:  PHP Startup: bz2: Unable to initialize module\nModule compiled with build ID=API20170718,NTS\nPHP    compiled with build ID=API20170718,TS\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: calendar: Unable to initialize module\nModule compiled with build ID=API20170718,NTS\nPHP    compiled with build ID=API20170718,TS\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: ctype: Unable to initialize module\nModule compiled with build ID=API20170718,NTS\nPHP    compiled with build ID=API20170718,TS\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'curl' (tried: /usr/lib64/php/modules/curl (/usr/lib64/php/modules/curl: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/curl.so (/usr/lib64/php/modules/curl.so: undefined symbol: core_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'dom' (tried: /usr/lib64/php/modules/dom (/usr/lib64/php/modules/dom: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/dom.so (/usr/lib64/php/modules/dom.so: undefined symbol: executor_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: exif: Unable to initialize module\nModule compiled with build ID=API20170718,NTS\nPHP    compiled with build ID=API20170718,TS\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'fileinfo' (tried: /usr/lib64/php/modules/fileinfo (/usr/lib64/php/modules/fileinfo: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/fileinfo.so (/usr/lib64/php/modules/fileinfo.so: undefined symbol: file_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: ftp: Unable to initialize module\nModule compiled with build ID=API20170718,NTS\nPHP    compiled with build ID=API20170718,TS\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: gettext: Unable to initialize module\nModule compiled with build ID=API20170718,NTS\nPHP    compiled with build ID=API20170718,TS\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'iconv' (tried: /usr/lib64/php/modules/iconv (/usr/lib64/php/modules/iconv: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/iconv.so (/usr/lib64/php/modules/iconv.so: undefined symbol: sapi_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'json' (tried: /usr/lib64/php/modules/json (/usr/lib64/php/modules/json: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/json.so (/usr/lib64/php/modules/json.so: undefined symbol: core_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'mbstring' (tried: /usr/lib64/php/modules/mbstring (/usr/lib64/php/modules/mbstring: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/mbstring.so (/usr/lib64/php/modules/mbstring.so: undefined symbol: compiler_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'pdo' (tried: /usr/lib64/php/modules/pdo (/usr/lib64/php/modules/pdo: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/pdo.so (/usr/lib64/php/modules/pdo.so: undefined symbol: executor_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'pgsql' (tried: /usr/lib64/php/modules/pgsql (/usr/lib64/php/modules/pgsql: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/pgsql.so (/usr/lib64/php/modules/pgsql.so: undefined symbol: executor_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'phar' (tried: /usr/lib64/php/modules/phar (/usr/lib64/php/modules/phar: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/phar.so (/usr/lib64/php/modules/phar.so: undefined symbol: compiler_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'simplexml' (tried: /usr/lib64/php/modules/simplexml (/usr/lib64/php/modules/simplexml: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/simplexml.so (/usr/lib64/php/modules/simplexml.so: undefined symbol: executor_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'sockets' (tried: /usr/lib64/php/modules/sockets (/usr/lib64/php/modules/sockets: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/sockets.so (/usr/lib64/php/modules/sockets.so: undefined symbol: file_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'sqlite3' (tried: /usr/lib64/php/modules/sqlite3 (/usr/lib64/php/modules/sqlite3: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/sqlite3.so (/usr/lib64/php/modules/sqlite3.so: undefined symbol: core_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'tokenizer' (tried: /usr/lib64/php/modules/tokenizer (/usr/lib64/php/modules/tokenizer: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/tokenizer.so (/usr/lib64/php/modules/tokenizer.so: undefined symbol: compiler_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/xml.so' (tried: /usr/lib64/php/modules/xml.so (/usr/lib64/php/modules/xml.so: undefined symbol: executor_globals), /usr/lib64/php/modules//usr/lib64/php/modules/xml.so.so (/usr/lib64/php/modules//usr/lib64/php/modules/xml.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: xmlwriter: Unable to initialize module\nModule compiled with build ID=API20170718,NTS\nPHP    compiled with build ID=API20170718,TS\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'xsl' (tried: /usr/lib64/php/modules/xsl (/usr/lib64/php/modules/xsl: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/xsl.so (/usr/lib64/php/modules/xsl.so: undefined symbol: dom_node_class_entry)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'pdo_pgsql.so' (tried: /usr/lib64/php/modules/pdo_pgsql.so (/usr/lib64/php/modules/pdo_pgsql.so: undefined symbol: file_globals), /usr/lib64/php/modules/pdo_pgsql.so.so (/usr/lib64/php/modules/pdo_pgsql.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'pdo_sqlite' (tried: /usr/lib64/php/modules/pdo_sqlite (/usr/lib64/php/modules/pdo_sqlite: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/pdo_sqlite.so (/usr/lib64/php/modules/pdo_sqlite.so: undefined symbol: core_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'wddx' (tried: /usr/lib64/php/modules/wddx (/usr/lib64/php/modules/wddx: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/wddx.so (/usr/lib64/php/modules/wddx.so: undefined symbol: ps_globals)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'xmlreader' (tried: /usr/lib64/php/modules/xmlreader (/usr/lib64/php/modules/xmlreader: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/xmlreader.so (/usr/lib64/php/modules/xmlreader.so: undefined symbol: executor_globals)) in Unknown on line 0
[Fri Aug 21 14:25:41.582954 2020] [mpm_event:notice] [pid 496550:tid 139767625967488] AH00489: Apache/2.4.46 (Unix) OpenSSL/1.1.1c PHP/7.2.33 configured -- resuming normal operations
[Fri Aug 21 14:25:41.582986 2020] [mpm_event:info] [pid 496550:tid 139767625967488] AH00490: Server built: Aug 17 2020 18:09:41
[Fri Aug 21 14:25:41.583002 2020] [core:notice] [pid 496550:tid 139767625967488] AH00094: Command line: 'httpd'

In Chrome browser after lookup phpinfo(); there are no additional modules.
But after
[master@tf ~]$ php -a
Interactive shell

php > phpinfo();
PHP Version => 7.2.33

System => Linux tf.rentech.ru 4.18.0-193.14.2.el8_2.x86_64 #1 SMP Sun Jul 26 03:54:29 UTC 2020 x86_64
Build Date => Aug  4 2020 07:35:57
Configure Command =>  './configure'  '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--program-prefix=' '--disable-dependency-tracking' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib64' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/var/lib' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib64' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--without-gdbm' '--with-jpeg-dir=/usr' '--with-openssl' '--with-system-ciphers' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--with-kerberos' '--with-libxml-dir=/usr' '--with-system-tzdata' '--with-mhash' '--enable-dtrace' '--libdir=/usr/lib64/php' '--enable-pcntl' '--enable-opcache' '--enable-opcache-file' '--enable-phpdbg' '--enable-mbstring=shared' '--enable-mbregex' '--with-gd=shared,/usr' '--with-gmp=shared' '--enable-calendar=shared' '--enable-bcmath=shared' '--with-bz2=shared' '--enable-ctype=shared' '--enable-dba=shared' '--with-db4=/usr' '--with-tcadb=/usr' '--enable-exif=shared' '--enable-ftp=shared' '--with-gettext=shared' '--with-iconv=shared' '--enable-sockets=shared' '--enable-tokenizer=shared' '--with-xmlrpc=shared' '--with-ldap=shared' '--with-ldap-sasl' '--enable-mysqlnd=shared' '--with-mysqli=shared,mysqlnd' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--enable-dom=shared' '--with-pgsql=shared' '--enable-simplexml=shared' '--enable-xml=shared' '--enable-wddx=shared' '--with-snmp=shared,/usr' '--enable-soap=shared' '--with-xsl=shared,/usr' '--enable-xmlreader=shared' '--enable-xmlwriter=shared' '--with-curl=shared,/usr' '--enable-pdo=shared' '--with-pdo-odbc=shared,unixODBC,/usr' '--with-pdo-mysql=shared,mysqlnd' '--with-pdo-pgsql=shared,/usr' '--with-pdo-sqlite=shared,/usr' '--with-sqlite3=shared,/usr' '--enable-json=shared' '--without-readline' '--with-libedit' '--enable-phar=shared' '--enable-sysvmsg=shared' '--enable-sysvshm=shared' '--enable-sysvsem=shared' '--enable-shmop=shared' '--enable-posix=shared' '--with-unixODBC=shared,/usr' '--enable-fileinfo=shared' '--without-sodium' '--enable-intl=shared' '--with-icu-dir=/usr' '--with-enchant=shared,/usr' '--with-recode=shared,/usr' 'build_alias=x86_64-redhat-linux-gnu' 'host_alias=x86_64-redhat-linux-gnu' 'LDFLAGS=-Wl,-z,relro -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld'
Server API => Command Line Interface
Virtual Directory Support => disabled
Configuration File (php.ini) Path => /etc
Loaded Configuration File => /etc/php.ini
Scan this dir for additional .ini files => /etc/php.d
Additional .ini files parsed => /etc/php.d/20-bz2.ini,
/etc/php.d/20-calendar.ini,
/etc/php.d/20-ctype.ini,
/etc/php.d/20-curl.ini,
/etc/php.d/20-dom.ini,
/etc/php.d/20-exif.ini,
/etc/php.d/20-fileinfo.ini,
/etc/php.d/20-ftp.ini,
/etc/php.d/20-gettext.ini,
/etc/php.d/20-iconv.ini,
/etc/php.d/20-json.ini,
/etc/php.d/20-mbstring.ini,
/etc/php.d/20-pdo.ini,
/etc/php.d/20-pgsql.ini,
/etc/php.d/20-phar.ini,
/etc/php.d/20-simplexml.ini,
/etc/php.d/20-sockets.ini,
/etc/php.d/20-sqlite3.ini,
/etc/php.d/20-tokenizer.ini,
/etc/php.d/20-xml.ini,
/etc/php.d/20-xmlwriter.ini,
/etc/php.d/20-xsl.ini,
/etc/php.d/30-pdo_pgsql.ini,
/etc/php.d/30-pdo_sqlite.ini,
/etc/php.d/30-wddx.ini,
/etc/php.d/30-xmlreader.ini

PHP API => 20170718
PHP Extension => 20170718
Zend Extension => 320170718
Zend Extension Build => API320170718,NTS
PHP Extension Build => API20170718,NTS
Debug Build => no
Thread Safety => disabled
Zend Signal Handling => enabled
Zend Memory Manager => enabled
Zend Multibyte Support => provided by mbstring
IPv6 Support => enabled
DTrace Support => available, disabled

....

pgsql

PostgreSQL Support => enabled
PostgreSQL(libpq) Version => 11.9
PostgreSQL(libpq)  => PostgreSQL 11.9 on x86_64-pc-linux-gnu, compiled by gcc (GCC) 8.3.1 20191121 (Red Hat 8.3.1-5), 64-bit
Multibyte character support => enabled
SSL support => enabled
Active Persistent Links => 0
Active Links => 0

....

Additional Modules

Module Name

Environment

....

it show pgsql without additional modules section.

It shows no errors also everywhere except httpd log.

All paths are correct.

Any ideas to test and look?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-08-21 13:54 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-08-21 13:54 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.
 [2020-08-21 14:09 UTC] bugrep at gmail dot com
the modules which are tried to load are simply from a different build, you try to mix ZTS versus non-ZTS binaries

ID=API20170718,NTS 
compiled with build ID=API20170718,TS
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Jul 19 18:01:30 2024 UTC