php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7990 include_path sometimes set wrong
Submitted: 2000-11-27 03:48 UTC Modified: 2000-12-30 19:43 UTC
From: franky dot van dot liedekerke at telenet dot be Assigned:
Status: Closed Package: PHP options/info functions
PHP Version: 4.0.3pl1 OS: Solaris 2.6
Private report: No CVE-ID: None
 [2000-11-27 03:48 UTC] franky dot van dot liedekerke at telenet dot be
I run apache 1.3.14 with php, and on a nulber of virtual hosts, I have the parameter
php_admin_value include_path "/path/to/include/dir"
set.
Now it happens that sometimes, not frequently, when I address a random virtual host, the include_path is set to the value of the first include_path mentioned in my config. A simple refresh solves this and the include_path is the correct one then.
Now I can't reproduce this, since it only happens occasionally, but I think it must have something todo with the initialisation of this value for a new proces.

Please contact me if you have any questions,

Franky

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-27 04:02 UTC] sniper@php.net
Please try latest snaphot from http://snaps.php.net/
to check if this is already fixed or not.

--Jani
 [2000-12-30 19:43 UTC] sniper@php.net
This should be fixed now. Try latest snapshot from http://snaps.php.net/

--Jani
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Sep 19 23:01:27 2019 UTC