php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79898 WeakReference constructor should be documented as private
Submitted: 2020-07-25 13:43 UTC Modified: 2021-05-22 12:22 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: michael dot vorisek at email dot cz Assigned: krakjoe (profile)
Status: Not a bug Package: *General Issues
PHP Version: 7.4.8 OS:
Private report: No CVE-ID: None
 [2020-07-25 13:43 UTC] michael dot vorisek at email dot cz
Description:
------------
like Closure constructor

is there a git repo to submit PRs like this to?

Test script:
---------------
-

Expected result:
----------------
-

Actual result:
--------------
-

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-07-25 14:19 UTC] requinix@php.net
-Type: Documentation Problem +Type: Bug -Package: Documentation problem +Package: *General Issues -Assigned To: +Assigned To: krakjoe
 [2020-07-25 14:19 UTC] requinix@php.net
The constructor is not private.

Not sure why it's public and throws an exception when called... @krakjoe?
 [2020-07-26 13:24 UTC] cmb@php.net
> Not sure why it's public and throws an exception when called

Perhaps to provide a more useful error message ("use ::create()
instead").
 [2021-05-22 12:22 UTC] krakjoe@php.net
-Status: Assigned +Status: Not a bug
 [2021-05-22 12:22 UTC] krakjoe@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jun 21 17:01:23 2021 UTC