php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79854 bench.php freeze on opcache.jit=1255
Submitted: 2020-07-13 17:04 UTC Modified: 2020-10-15 12:35 UTC
From: naym333 at gmail dot com Assigned: nikic (profile)
Status: Closed Package: opcache
PHP Version: 8.0.0alpha2 OS:
Private report: No CVE-ID: None
 [2020-07-13 17:04 UTC] naym333 at gmail dot com
Description:
------------
Standard bench.php from https://github.com/php/php-src/blob/master/Zend/bench.php freeze on nestedloop step if `opcache.jit=1255`, but, if remove `$x++` everything is ok

Test script:
---------------
https://github.com/DmitryNaum/php8-bench

Expected result:
----------------
everything is work

Actual result:
--------------
freeze

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-10-15 12:35 UTC] nikic@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: nikic
 [2020-10-15 12:35 UTC] nikic@php.net
Can't reproduce this on current PHP-8.0. A lot has changes since alpha 2, so this was likely fixed in the meantime. Please tell me if you still see the issue.
 [2020-10-22 14:37 UTC] celestinoxp at hotmail dot com
I have same problem. I'm testing 1255 value for opcache.jit and apache starts normally. But only works in certain php pages...

In my case i following this steps:

1º - in php.ini --> opcache.jit = 1255
2º - start apache --> ok
3º - open link: http://localhost/dashboard/phpinfo.php --> ok
4º - open link: http://localhost/phpmyadmin --> apache crashes --> apache restart and link not open.
5º - refresh browser --> apache crashes --> apache restart and link not open.

I'm using:
- windows 10 (64 bits).
- PHP Version 8.0.0-dev (Build date: Oct 21 2020 23:40:32).
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Oct 28 03:01:23 2020 UTC