php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79834 Segaults while running composer 2.0
Submitted: 2020-07-11 11:37 UTC Modified: 2020-07-11 14:31 UTC
From: graham at alt-three dot com Assigned:
Status: Closed Package: Reproducible crash
PHP Version: 8.0.0alpha2 OS: Ubuntu 18.04
Private report: No CVE-ID: None
 [2020-07-11 11:37 UTC] graham at alt-three dot com
Description:
------------
https://github.com/GrahamCampbell/uri-template/runs/860790102?check_suite_focus=true

2020-07-11T11:32:19.3544862Z   - Installing myclabs/deep-copy (1.10.1): Extracting archive
2020-07-11T11:32:19.3566551Z   - Installing phpunit/phpunit (dev-master b57cd45): Extracting archive
2020-07-11T11:32:56.8421852Z Segmentation fault (core dumped)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-07-11 14:31 UTC] graham at alt-three dot com
-Status: Open +Status: Closed
 [2020-07-11 14:31 UTC] graham at alt-three dot com
Looks like this was fixed a few hours ago on master. My test run was on master from 12 hours ago... and it was fixed in between times!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 29 15:01:25 2020 UTC