php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79789 Assertion `!(executor_globals.exception) || ret == T_ERROR' failed
Submitted: 2020-07-04 18:33 UTC Modified: 2020-07-07 10:03 UTC
From: changochen1 at gmail dot com Assigned:
Status: Duplicate Package: Scripting Engine problem
PHP Version: 8.0Git-2020-07-04 (Git) OS:
Private report: No CVE-ID: None
 [2020-07-04 18:33 UTC] changochen1 at gmail dot com
Description:
------------
LOG:
---
php: /home/yongheng/php_clean/Zend/zend_compile.c:1792: int zendlex(zend_parser_stack_elem *): Assertion `!(executor_globals.exception) || ret == T_ERROR' failed.
---

Test script:
---------------
<?
function b ( $a =   array () [ array () ]  ) {
    eval ( 2 );}
b () ;


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-07-07 10:03 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2020-07-07 10:03 UTC] nikic@php.net
This has the same root cause as bug #79790.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Sep 27 20:01:23 2020 UTC